Requirements

Please make sure that your server meets the requirements: https://elementor.com/help/requirements/

To run WordPress and use the theme properly we recommend your host supports:

  • PHP Version 7.4 or greater
  • Upload Max Filesize 64M
  • Memory limit 256M
  • Max Execution Time 360
  • Post Max Size 64M
  • HTTPS support

Ask for it

Send a letter to your hosting provider, just copy and paste it:

I’m interested in running the open-source WordPress <https://wordpress.org/> web software and I was wondering if my account supported the following:

  • PHP Version 7.4 or greater
  • Upload Max Filesize 64M
  • Memory limit 128M
  • Max Execution Time 360
  • Post Max Size 64M
  • HTTPS support

Thanks!

Site Health Status

In your WordPress dashboard proceed to the Tools > Site Health tab and make sure that all the recommended WordPress modules are enabled on your server. There shouldn’t be any critical issues in the Site Health Status as well.